What devices are compatible with Kiosk Pro?

The short answer is that Kiosk Pro is compatible with devices running iOS 9.3.5 or later.

The iOS is the operating system used by iPad, iPhone, and iPod (like Windows is the operating system used on many PC's). You can often update the iOS for free without getting a new device, although at some point Apple stops offering upgrades to the latest iOS on older devices.

If you have the option, we recommend selecting newer devices as they will have better overall performance and stability in this type of 24-7 use case. 

In terms of tablets, we currently support:

  • 12.9-inch iPad Pro (released 2015, updated 2017, 2018)
  • 11-inch iPad Pro
  • 10.5-inch iPad Pro
  • iPad (released 2017, updated 2018)
  • 9.7-inch iPad Pro
  • iPad Air 2
  • iPad Air
  • iPad 4
  • iPad 3
  • iPad 2
  • iPad Mini 4
  • iPad Mini 3
  • iPad Mini 2
  • iPad Mini

You will not be able to purchase or install new versions of Kiosk Pro on the original iPad, iPhone, or iPhone 3G, and early generations of iPod touch.

Still stuck? How can we help? How can we help?